Forum

[Solved] Ambilight doesn't work after latest FW Update  

  RSS

zelectah
(@zelectah)
Active Member
Joined: 2 months  ago
Posts: 8
12/10/2018 2:48 pm  

Hello,

I finally got my second pair of Yeelights. But I figured out, after updating all bulbs to the newest firmware, Jeelight can still recognize them but when starting the ambilight, they doesn't response.

Curious is, on my other pc, the 2 older ones are still working with ambi after the update, but the 2 new ones also don't response.


ReplyQuote
zelectah
(@zelectah)
Active Member
Joined: 2 months  ago
Posts: 8
13/10/2018 12:48 pm  

Hello,

gave it another try and I believe it is not the FW Update which is causing the problems.

Is it possible that jeelight couldn't handle more then 2 lights for ambilight?

I deleted all 4 bulbs out of the list and tested every combination. Everytime, just 2 bulbs are responding to the ambilight function.


ReplyQuote
Blueforcer
(@blueforcer)
Developer Admin
Joined: 4 months  ago
Posts: 30
13/10/2018 8:10 pm  

JeeLight can handle up to 8 Lights at the same time.

Try to open your Configfolder under "File" and delete the "device" file..restart Jeelight und try to add your lights again.


ReplyQuote
zelectah
(@zelectah)
Active Member
Joined: 2 months  ago
Posts: 8
14/10/2018 8:05 am  

Do you mean the JeeLight.cfg in the "app" folder? Cant find another config file in the Jeelight folder.


ReplyQuote
Blueforcer
(@blueforcer)
Developer Admin
Joined: 4 months  ago
Posts: 30
14/10/2018 5:49 pm  

No, in jeelight just click on "file" in the top left corner and choose configfolder


ReplyQuote
zelectah
(@zelectah)
Active Member
Joined: 2 months  ago
Posts: 8
14/10/2018 6:25 pm  

Hi,

did it and same happened again. All 4 are recognized and connected. After setting all 4 "zones" again just the first 2 are starting with the ambilight testvideo.

I also deleted the log file and this is what is written after the last test:

 

mouseClicked
open
Waiting for Light 1
set Musicmode for 1 to true
Light 1 connected!
Waiting for Light 2
set Musicmode for 2 to true
Light 2 connected!
Waiting for Light 3
set Musicmode for 3 to true
Light 3 connected!
Waiting for Light 4
set Musicmode for 4 to true
Light 4 connected!
Ambilight started
Start Thread 1
Start Thread 2
Start Thread 3
Start Thread 4
(RuntimeException) java.lang.RuntimeException: Object should first be initialized (B4XBitmap).
Thread 1 started
Thread 2 started
mousePressed
mouseReleased
mouseClicked
Exit

 

Hope it can help us.


ReplyQuote
Blueforcer
(@blueforcer)
Developer Admin
Joined: 4 months  ago
Posts: 30
14/10/2018 11:09 pm  

Please try to deactivate multithreading since it is highly experimental. According to the log it crash in two threads

This post was modified 2 months  ago 2 times by Blueforcer

ReplyQuote
zelectah
(@zelectah)
Active Member
Joined: 2 months  ago
Posts: 8
15/10/2018 10:48 am  

Awesome, now it is working like a charm. Thank you very much.

Gave it a test run, if you want to take a look:

TEST

 


Blueforcer liked
ReplyQuote
Share:
  
Working

Please Login or Register