Forum

[Solved] ambilight responsiveness  

  RSS

elephant
(@elephant)
Active Member
Joined: 3 months  ago
Posts: 8
19/09/2018 11:00 pm  

I have set up Ambilight with two lights and two small-ish zones on my display. 

When playing a video on fullscreen there is a delay of around 1-2 seconds for the light colours to update with the image on screen.

Is there a combination of parameters/settings that would help with the delay?

If I hit pause when the video is playing the lights update their color much faster.

 


ReplyQuote
Blueforcer
(@blueforcer)
Developer Admin
Joined: 4 months  ago
Posts: 30
19/09/2018 11:11 pm  

This can have several causes. First of all it would be interesting what hardware you have. It sounds like your PC is too weak. In addition I would have to know which ambilight settings you have made.

What is the reaction time in the playground?


ReplyQuote
elephant
(@elephant)
Active Member
Joined: 3 months  ago
Posts: 8
19/09/2018 11:55 pm  

I am using a 2016 macbook pro 13in with the i5 cpu.

Ambilight is set with speed at 300 and only "switch black to blue" and "beta commands" on.

In playground, there is basically no delay when i select a color. Maybe 0.2 seconds 


ReplyQuote
Blueforcer
(@blueforcer)
Developer Admin
Joined: 4 months  ago
Posts: 30
20/09/2018 12:19 am  

Do you have the beta firmware on your yeelights? If not disable beta commands


ReplyQuote
elephant
(@elephant)
Active Member
Joined: 3 months  ago
Posts: 8
20/09/2018 8:27 pm  

I've disabled it and there is no much difference. I have noticed that as soon as i start Jeelight it the ambilight mode works well for the first five minutes or so of video playback and then it starts having a 3-5 seconds delay.

 


ReplyQuote
Blueforcer
(@blueforcer)
Developer Admin
Joined: 4 months  ago
Posts: 30
20/09/2018 10:14 pm  

Can you tell me your CPU load and RAM usage after this 5 Minuten during the playback? It looks like a memory leak, but its the first time i heard this. And Plesse try to Connect your mac to the network via Ethernet. Maybe your wifi is overloading vor your Router is cutting something

This post was modified 3 months  ago by Blueforcer

ReplyQuote
elephant
(@elephant)
Active Member
Joined: 3 months  ago
Posts: 8
20/09/2018 10:34 pm  

10-20% cpu and around 400Mb of ram. Using ethernet connection,

 


ReplyQuote
Blueforcer
(@blueforcer)
Developer Admin
Joined: 4 months  ago
Posts: 30
20/09/2018 11:10 pm  

Thats weird. Looks normal.

I will compile a Testversion with some timing outputs for you. 


ReplyQuote
elephant
(@elephant)
Active Member
Joined: 3 months  ago
Posts: 8
20/09/2018 11:13 pm  

Thanks a lot for your help. I think this is an amazing app you've made and I'd love to have it work at its best!


Blueforcer liked
ReplyQuote
Blueforcer
(@blueforcer)
Developer Admin
Joined: 4 months  ago
Posts: 30
21/09/2018 10:53 am  

I just tested it on my 2011 Macbook..and you're right.
But theres some crazy things happening. JeeLight work as expected..Timings around 10-20ms ..but:

I made some tests with youtube.

As soon jeelight is in the background (in Fullscreen or completely behind the safari window) the delay happen. But as soon i move the mouse the delay is gone immediately. And if i move the jeelight window a little bit to one side so you can see it few millimeters beside the safari window there is no delay the whole time. Can you confirm that?

I don't know much about macOS, but everything indicates that the operating system prioritizes hidden applications very low. Maybe there is an option to disable that. I have too ask my friend google...

 

Funfact: if i hiding JeeLight  i can't see the timings. But when i see them, there is no delay xD

This post was modified 3 months  ago by Blueforcer

ReplyQuote
elephant
(@elephant)
Active Member
Joined: 3 months  ago
Posts: 8
21/09/2018 2:32 pm  

Yes I'm getting the same behavior.


ReplyQuote
Blueforcer
(@blueforcer)
Developer Admin
Joined: 4 months  ago
Posts: 30
21/09/2018 5:59 pm  

I try some workarounds later


elephant liked
ReplyQuote
Blueforcer
(@blueforcer)
Developer Admin
Joined: 4 months  ago
Posts: 30
22/09/2018 6:49 pm  

Well, I've got it.

its caused by an energy saving function added in MacOS 2013, called App Nap
https://www.howtogeek.com/277414/what-is-app-nap-is-it-slowing-down-my-mac-apps/

Sadly it doesn't seem that you can disable App Nap for a single Java Application. But i will try to figure it out.

For now you can disable App Nap entirely with

defaults write NSGlobalDomain NSAppSleepDisabled -bool YES

and re-enable  it with

defaults delete NSGlobalDomain NSAppSleepDisabled

 


ReplyQuote
Blueforcer
(@blueforcer)
Developer Admin
Joined: 4 months  ago
Posts: 30
25/09/2018 3:13 pm  

Edit:

you can disable App nap only for JeeLight with:

defaults write jee.light.JeeLight NSAppSleepDisabled -bool YES


elephant liked
ReplyQuote
Share:
  
Working

Please Login or Register